Page 2 of 2 FirstFirst 12
Results 26 to 37 of 37

Thread: AssetBundles as Audio players

  1. #26
    Alrighty so I feel dumb for not doing that part. I got that all working, and I even was able to properly import the cube into TTS.

    Now the issue is that while I changed I believe the correct sound file (the number four slot) to use the music I was trying, it doesn't update and stays at the song you originally set it to.

    [url=]Looks like this.[/url]

    Any ideas?

  2. #27
    An assetbundle is created from the Prefab, that's the bit that's connected to the assetbundle name when you "build it" but if you make your alterations on an active object in the Hierarchy panel you'll need to make sure you apply these changes so they feed back into the Prefab your working object is created from . . . think of it as your working on a copy but need to transfer the alterations you make back to the original before you export it.

    So once you make your changes in the inspector panel Top left corner click on "Apply" to make sure this is happening. Then try and build your assetbundle again. before we go any further

  3. #28
    Ah, I got it, thanks!

    Different issue now, though. When I pull the asset bundle into TTS, it spawns two linked cubes that function as a single object, and it has 8 slots for music.

    [url=]This is what I'm talking about.[/url]

    Clearly I did something wrong, but I can't figure out how I managed to pull this one off.

    Edit: Also, is there a way to edit the volume of the cube? I messed with the volume settings in TTS and none of the sliders had any effect on the volume of the sounds played from the cube.

  4. #29
    This is One of two things, you've either duplicated the model in the scene and applied it to the Prefab before you built the Assetbundle and exported it.

    Or you have two separate objects both assigned with the same Assetbundle name in your project so when you build. . . it builds both together as a single item.

    Easiest way to find out is to select the Prefab you want to export and change its Assetbundle name before you build it. this way you can be sure your not accidentally sweeping up another prefab by mistake.
    Last edited by Lucky seven; 05-04-2017 at 06:12 AM.

  5. #30
    I linked the soundfiles to the TTS asset bundle effects script, but now it just fails to load into TTS
    Last edited by Judasilfarion; 07-02-2017 at 11:54 AM.

  6. #31
    Hey Judasilfarion, Welcome to the Community

    Roll back a bit with this one.... What have you done ? give as much detail as you can.

  7. #32
    Quote Originally Posted by Lucky seven View Post
    Hey Judasilfarion, Welcome to the Community

    Roll back a bit with this one.... What have you done ? give as much detail as you can.
    I opened up the SOUND CUBE EXAMPLE.unitypackage file in unity, deleted the original sound files in the sounds file, replaced them with my own, then I opened the Sound Cube 1.prefab object. I opened the trigger effects tab under TTS Asset Bundle Effects (Script), opened the sound tab under sound 1, replaced the audio with one of the sound files in the sound folder, and repeated this for sound 2, 3 and 4.

    I renamed all the new sound files after the original ones

    Then I built assetbundles, imported it into Tabletop Simulator cloud file manager, and pasted the link into an assetbundle. When I did that however the assetbundle failed to load.

    Earlier I tried it without linking the audio files though, and it was imported just fine, but it didn't play any sound because the triggers weren't linked to anything

    EDIT: It seems that the problem isn't that I did anything wrong, but rather that Tabletop Simulator doesn't like to comply. The first time I import an assetbundle it works, but any further attempts to import assetbundles results in failure until I restart the game.
    Attached Images Attached Images
    Last edited by Judasilfarion; 07-02-2017 at 05:33 PM.

  8. #33
    Join Date
    Sep 2016
    Thanks for this. To my knowledge this is still the only tutorial for making sounds.

    Quick question, does the duration field matter for non-looping effects? I changed it anyway, but I'm just curious.

  9. #34
    Can we control the volume yet?
    Last edited by gir489; 08-31-2018 at 02:33 PM.

  10. #35
    Oh boy. This is the best tutorial I've found for doing importing sound effects in TTS and there haven't been responses from the author in over 2 years. Here's hoping someone can help me, because I have no idea what I'm doing.

    I followed pretty much the same steps as Judasilfarion. Since it's 2019 now and there have been several updates to Unity since Custom AssetBundles started with Unity 5.6.5, I *assume* (possibly incorrectly) that using a newer version, like Unity 2019.2.9f1 would not be a problem. I guess I should also download the old version and try re-building everything there... Anyway. I created a total of 5 sound cubes, each with 5-15 sound effects linked in it. I started with the pre-fab sound cube provided by Lucky Seven, and adjusted the assets as described by Judasilfarion. Each time I clicked "Build Assetbundle" it created a new ".unity3d" object with the different filenames that I had chosen. Unfortunately, I did not have the foresight to save as a different project for each cube, and instead went through the process of "delete sound assets, upload new sound assets, rename and re-link each asset in the Inspector panel, rename everything" for each of the remaining 4 cubes. In the end, I have a Project/AssetBundles folder with my 5 ".unity3d" files.

    When I go to upload them into TTS (Objects -> Components -> Custom -> AssetBundle), I can navigate to any of my files and upload it to the Steam Cloud (Main only, Secondary blank), click "Import", and a cube appears and falls through the table, then the "Custom AssetBundle" window pops open again with my Steam Cloud URL still in place. I can continue clicking "Import" and it just keeps looping the process. If I select the example "sound cube 1.unity3d" file to upload to the Steam Cloud, then click Import, I get a notice about the Shader not loading correctly but it still spawns the cube and it works as expected. I don't know what could possibly be wrong, other than my using a newer version of Unity.

    EDIT: Well, I just downloaded Unity 5.6.5f, imported the Sample Sound Cube package, made my adjustments for my first (of five) cubes, built the AssetBundle, and tried importing it in TTS before continuing... And it worked! I guess it really does still have to be the old version of Unity. Good to know, for every else's future reference!
    Last edited by Nefenjo; 10-13-2019 at 11:23 PM.

  11. #36
    Join Date
    Dec 2019
    Same here, followed the steps as they were explained but still it's not working

  12. #37
    Yeap, the same problem remains

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts