Results 1 to 3 of 3

Thread: Bug - Physics Freakout after State change

  1. #1

    Bug - Physics Freakout after State change

    Note: messed up on forum usage -- please move this to bug report. sorry!

    Not going to be terribly helpful bug report, due to the elusive nature of this bug.

    Seems to be an issue with physics, custom models, state changes, and something specific to a client session.

    1) Simple custom models with heavy scripting organized into 2 states, set as Board type.

    2) When I loaded a save game with these objects, and an instance of the object in the State 2 slot did not already exist in the game (loaded), this would happen:
    I would change to state 2, and that object would begin to jitter, catch on objects, begin rotating into the air, floating up, almost as if gravity was gone and random force was being applied.

    3) Changing a quality on the object, such as updating the type, would make it immediately fall and act normally.

    4) If I loaded the same save game, but with one of the State 2 objects already existing in the game (so loaded), then I could not replicate the bug. State change went smoothly as normal.

    So seems to be an issue with loading the object when it doesn't already exist.

    5) Did not affect other custom models that I tried with same setup.

    6) Restarting server did not fix problem.

    7) But restarting game DID solve the problem completely. I can no longer replicate the bug.


    8) Something similiar has happened to me twice recently in the past several weeks. Things are functioning normally, and then suddenly, objects begin freaking out -- or I'm unable to grab and move objects -- almost as if they are locked, but I can grab them almost as if they were not.


    9) all of this began several weeks ago. I encountered a perpetual load issue with a takeObject fcn from a bag, and tried playing with game settings to fix, such as vsync, etc. Then I even uninstalled/reinstalled the 2012 Visual C+++ x86 based on common suggestions from devs.

    In all cases, the issue can be resolved by restarting the entire game, not just the server.
    Last edited by Eskander; 09-20-2016 at 10:03 AM.

  2. #2
    what you've described sounds a lot like this report from Dig65

    [url]http://www.berserk-games.com/forums/showthread.php?2967-Weird-quot-spiral-flying-quot-from-items-copied-spawned-added-from-chest[/url]

    An initial state change acts much like a first spawn of an item....was this similar to what you were seeing ?

    If so This should be fixed in the hotfix v8.0.3.

    When did you last see this behaviour occur ...before or after this latest Hotfix ?

  3. #3
    1) I saw that video -- similar in terms of almost a spiraling force, but my object seemed a bit more jittery and less smooth of a movement, also much slower... more like yoda lifting xwing speed instead of neo blasting off -- also was resistant to grabbing it and getting it under control.

    2) Experienced it last night around 10pm EST or so. Guessing that's after the hotfix eh?

    Also I note this custom object's scripts had a bojillion buttons. Many of which use a trick of setting button size to 0, 0, so it acts as an actual text tool that follows the object instead of a button.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •