Results 1 to 2 of 2

Thread: Tabletop Simulator isn't launching

  1. #1

    Tabletop Simulator isn't launching

    I have a major serious problem. This day I have played Tabletop Simulator (it worked perfectly), but when I tried to launch it a few hours later, it wouldn't start. I am stuck at the message "preparing to launch Tabletop Simulator" on Steam and it won't start or disappear. Not even an error message. I also tried to launch it from the Desktop, but without success. It just acknowledges that I tried to launch it by the loading cursor for a few milliseconds and it stops running.

    I even removed Steam and the Steam-related games within, reinstalled, "redownloaded" and nothing.

    I need to play TTS, I have many hours in it and the game is a purchased/gift version. What can I do? Is my copy ruined forever?

    Thanks in advance!

  2. #2
    It seems that is solved itself, when I tried the next day

Similar Threads

  1. [SUPPORT] Having trouble launching Tabletop Simulator
    By dougputhoff in forum Technical Support
    Replies: 1
    Last Post: 02-15-2017, 01:44 PM
  2. Questions about IRC and Tabletop Simulator
    By Tragic in forum General Discussion
    Replies: 1
    Last Post: 02-15-2017, 01:36 PM
  3. Portable TableTop Simulator?
    By AntiMetaman in forum General Discussion
    Replies: 6
    Last Post: 07-27-2016, 03:17 PM
  4. [ADDED] [v7.4] Tabletop Simulator VR
    By Pollix in forum Suggestions
    Replies: 2
    Last Post: 06-06-2016, 06:41 PM
  5. No startup of VR Tabletop Simulator
    By Dannaman in forum VR Support
    Replies: 2
    Last Post: 06-04-2016, 12:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts