Results 1 to 14 of 14

Thread: [CRASHES] Crash while repeatedly testing script changes

  1. #1

    [SOLVED] Crash while repeatedly testing script changes

    Steps to Reproduce:
    1. Download the `[URL=""]Hoard Card Game[/URL]` from [URL=""]my workshop[/URL]. (currently set to private while being worked on, but I'm assuming as an admin you are good to go)
      1. NOTE: I've duplicated this using just my card dealing script. It's publicly available here: [URL=""]Crash Test[/URL]
    2. Load the game
    3. Click the 'Deal New Hoard' button on the table to the lower right.
    4. Load the scripts into Atom using the plugin. Make some small changes and reload a bunch.
    5. Go to 3

    After a while (maybe testing 20+ changes?) the game will crash while dealing cards.

    Expected Results:
    The game doesn't crash.

    Some details and possible root causes:
    • The first time, I thought it was a fluke as Tabletop Simulator is usually rock solid
    • The crash is inconsistent but has happened a few times now starting a few days ago. (Also note this is the first Tabletop Simulator project I've worked on which I also started a few days ago.)
    • Often when it happens I've stopped reloading edits and am simply testing repeatedly, but I haven't been able to reproduce it from simply dealing cards without using the editor.
    • I just installed Google's new 'Backup and Sync' and set my 'Documents' folder to get automatically backed up. Now that I've done that, I sometimes get sharing violations from the auto saves. (e.g. "Error saving image: Sharing violation on path C:\Users\...\TS_AutoSave.png") Maybe a different sharing violation is causing the crash? Unfortunately there's no way to exclude specific folders from 'Backup and Sync', but I'll turn it off and see if it helps.
    • On the other hand, it seem to happen while the script is running and cards are being dealt. Could also be a coincidence.
    • The script I'm running will destroy all non-essential decks and cards and pull a new deck from an infinite bag each time the 'Deal New Hoard' button is clicked. Maybe too many objects are getting instantiated/destroyed?
    • NOTE: I've been able to duplicate this crash on other computers. Seems to happen more often and without using the script editor.

    Here are some crash logs for you:

    OS: Win10

    Hope that helps!

    Last edited by bjennings76; 09-14-2017 at 11:46 PM. Reason: Marking as resolved as I'm not able to reproduce it anymore.

  2. #2
    Whoops. I just realized this post is in the wrong place and I don't see a 'Delete' button. Can someone move it to 'Technical Support' please?

  3. #3
    I think perhaps the Scripting Section might offer up better results for you than technical

    Thread Moved

  4. #4
    Hmm. Looks like there thread was moved to VR support. I think I might take you up on that scripting support forum suggestion. Could you nudge me over one more time?

  5. #5
    Apologies...napping on the job

  6. #6
    No worries. Thanks for the help!

    Hopefully the info helps the devs.

  7. #7
    Okay, I've got more info for anyone available! I've updated it in the original post, but if anyone could test out this public workshop project called [URL=""]'Crash Test'[/URL], I'd appreciate it. Just hit the 'Deal' button in the center of the table a few times and see if Tabletop Simulator crashes on you. I'll do so on different machines for me.

    Crash Test: [URL=""][/URL]

    Just install and run it and press the button. It'll do a little card dealing animation for ya usually, but sometimes it will crash the application.

    For those interested in yet more crash logs, here you go:

    Thanks for the help!

  8. #8
    I get an image not found error on loading: [url][/url]

    Apart from that I hit it a bunch of times and it didn't crash. I am on a mac though, well test PC later.

  9. #9
    bjennings, I just downloaded this and tested it on my windows machine, no problems at all on my end. Very neat, I love how it deals.

  10. #10
    It doesn't crash for me after dealing ~20 times and mashing it repeatedly for a bit, Win7 x64

  11. #11
    I did same as dzikakulka on win 7 x64, no crash.

  12. #12
    Hmm... both my computers must be set up wrong somehow, then. Possibly other software running in the background like Unity? I tried it again last night and it ran fine. *shrugs*

    Thanks all for the tests everyone!

  13. #13
    Join Date
    Apr 2016
    Time for the computer to reboot Fixes all the problems.

  14. #14

Similar Threads

  1. Replies: 4
    Last Post: 05-14-2017, 07:17 PM
  2. Replies: 0
    Last Post: 04-10-2017, 08:58 AM
  3. Keybinds not working.
    By Grail in forum General Discussion
    Replies: 2
    Last Post: 10-26-2016, 12:34 PM
  4. printToColor() not working?!
    By Lycake in forum Scripting
    Replies: 4
    Last Post: 03-08-2016, 12:55 PM
  5. [SOLVED] Microphone not working - PLS help
    By Brian Marlus in forum Technical Support
    Replies: 1
    Last Post: 08-17-2015, 02:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts