Not much info i can give you, I am a developer myself so I've tried everything i could imagine, even all options described here and on your steam post, cant even get it to produce a log.

Google and searching this forum finds me no solutions either.

The best i was able to manage was when starting the game directly from terminal i get:
[user name]@[computer name]:~/.steam/steam/SteamApps/common/Tabletop Simulator$ ./Tabletop\ Simulator.x86_64
Set current directory to /home/[user name]/.steam/steam/SteamApps/common/Tabletop Simulator
Found path: /home/[user name]/.steam/steam/SteamApps/common/Tabletop Simulator/Tabletop Simulator.x86_64
There is no data folder

This is on a Ubuntu 17.04 with nvidia binary driver v 384.90 using the steam version of the game at buildID 2163676

Runing on a:
intel core i7-4790K clocked att 4Ghz
32 gig ram
GeForce GTX 780 2304 cuda cores, 3072 mb video ram

If i can provide you with anything more, just ask.

As i said, tried everything i could imagine as well as the "Having issues" from your steam post