Results 1 to 2 of 2

Thread: Anime style flat shading (Unlit shader) materials appear somewhat transparent

  1. #1

    Anime style flat shading (Unlit shader) materials appear somewhat transparent

    Hi, I'm trying to import some anime characters into TTS using Unity.

    In Unity, changing the materials to "unlit/texture" looks great (flat shading). After creating the asset bundle, and importing into TTS, the unlit surfaces appear partially transparent. On the other hand, it looks perfect in Unity.

    Is this an intended behaviour, or am I doing it wrong? Is there a fix for this?

    Cheers.

  2. #2
    Thanks to Locoparentus on discord, we've worked out the issue to be this:

    "If I remember rightly I think the Unlit texture shader is Ignored by the third party Ambient Occlusion Effect/layer TTS adds to the room so What I guess your seeing is the AO effect of the objects behind it through your unlit texture model."

    The problem is fixed by turning off SSAO in the graphics settings in TTS.

    Is this fixable in a future update?

Similar Threads

  1. Replies: 1
    Last Post: 05-12-2016, 01:40 PM
  2. Adding a materials tab to custom cards
    By Lucky seven in forum Suggestions
    Replies: 5
    Last Post: 09-12-2015, 12:15 AM
  3. Replies: 0
    Last Post: 07-09-2015, 05:19 PM
  4. Making Flat Figurines
    By Smoking Rat God King in forum General Discussion
    Replies: 3
    Last Post: 01-30-2015, 03:20 AM
  5. Flat counters
    By Keybounce in forum General Discussion
    Replies: 2
    Last Post: 01-30-2015, 02:20 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •