Results 1 to 14 of 14

Thread: Custom card decks are white upon opening save file

  1. #1
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    This will hopefully be my last gripe for a while, everything else seems to be working reliably for me. My issue is after creating a few custom decks for my game, when I leave and go back to the program later. All my decks are now blank white cards, as seen in this shot:

    [url]http://imgur.com/uDhIJaO[/url]

    I've looked through all the pages of the forum and hadn't come across this exact problem, at least not solved. It sounds like others have had issues with content not loading, but can clear the cached images on their hard drive and that forces a redownload and the content shows up. But that doesn't work in this case. I don't know if it's a size issue, though I'd been lucky enough to go a day or so with custom decks loading fine from a save file and their images were the same as I'm using now. Just to make sure, I tried resizing down to 4096 px wide, but that didn't cure it. I thought maybe Copy.com wasn't a good site to use as a source, but I've got dozens of chits and the game boards uploaded there and they load fine. There are no error messages in the console.

    It's very frustrating to spend a few days scanning hundreds of cards and making over a dozen decks and to run into this wall for seemingly no reason, when everything else custom made loads without any problem.

  2. #2
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    Email me your save and I'll check it out BerserkGames@gmail.com.

  3. #3
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    Just sent it over, thanks a lot.

  4. #4

    Custom card decks are white upon opening save file

    I am having this issue as well. Saves with custom cards that loaded fine with 2.9 will now stop loading and leave the decks all white. I don't know if it is related or not, but I first noticed the problem in 3.0 when I changed a file name for a deck image on dropbox. However, the images were cached in Mods/Images so I am not sure how that would have actually affected anything.

  5. #5
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    I'm looking into the issue now what it looks like has happened is the front and back textures have some how gotten out of sync, so that the numbers do not match up. If you have any other saves that this occurs on please email it to us.

  6. #6
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    I understand issues like this can't be squashed in a couple minutes, but I'm curious if you can say if it's something that once the problem is resolved it could fix itself on that save or if it's a lost cause? I started a new save file and have been adding decks one by one and saving to see if I have better luck. So far so good, but I'm not looking forward to having to add the dozens of unique counters. And I'm worried about the same thing happening to the decks eventually and all this work being for naught...so that's dampened my excitement about trying to start with a new fresh file.

  7. #7
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    Unfortunately because the decks have became desynced it doesn't look like it's something that can be fixed after the fact. Did you by chance make the save after a failed load?

  8. #8
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    Thanks, that's unfortunate, but it's good to know! Well, the way I've been working had been with only one save. I'd add a few decks, save, add some counters, save, add the boards and some more counters, save, add decks..etc, etc. And so only once I'd spent a while on it, closed the program and came back to it later did I have the white decks pop up. I guess going forward it might be smarter to work in incremental saves instead of one save file.

    Edit: Oh wow, I didn't realize that the save files "remembered" as things were added and you can browse through and add those elements to another save file. I just reloaded everything I'd made into my new save file in just a few seconds. Now I just have to organize the pieces neatly again. Getting started again wasn't nearly as horrific as I thought it would be.

  9. #9
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    Aaaaand now my saves pretty much always crash, apparently due to high RAM usage. I think I'm done with the program for a while. I don't really understand it..I was doing incremental saves, I'd add a few things save as, we'll say, #4. Close, open that file again with no issue, add some things, save #5, open again, continue. And then at some point, it'd crash at around the ~90% mark and I couldn't even go back and open the previous files without them crashing too.

    Can you have too many pieces? Too many cards? I'll think I have a possible solution, like too many cards...but then I'll download mods on Steam that seem to have as many or more cards and they open fine. I'll try to shrink my images down, but that does nothing to help....I was wondering, why is a 2 Mb image I've made a 6 MB image once downloaded through the game and put in the cached image folder? And for fun I'll go look in the downloaded images folder at the files for those aforementioned mods and, of course, there are card deck files in there that are almost ten times as large as mine and loaded fine. Looking back at the forums, I'm going to guess I just have too many cards. And that's just too many cards at the point, I have about 400 in the game now, and I still have a few hundred more to add. So if the game's already choking with 8 gb of RAM now, there's not much point in me continuing on.

    I know it's an early access title, and I'll keep checking back as updates come along, it's just too frustrating and discouraging to run into issues where it appears others didn't and have no clue what to do, or if you even can do anything.

    I suppose if they're any help and I'm wrong about it being a RAM problem, here are a handful of crash logs from today.

    https://copy.com/vgTGURHUnOgSbyNJ

  10. #10
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    Does the crash also happen if you reboot the game and try to open the save? Feel free to link the save here and I can take a look at what's going on. 400+ cards shouldn't be an issue if you are using the decks well (ie, using up most of the template).

  11. #11
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    Yeah, I'd tried restarting the program and rebooting the computer, no fix. I've got several decks that are only ~20 cards, I've made pretty much every separate game deck it's own deck in tabletop simulator but I could probably combine a lot without the card #70 image needing to be unique. I'll work on that tomorrow. Here's my recent save.

    https://copy.com/EosiYMsUpxVO3VtR

  12. #12
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    Using it doesn't crash on my end but it definitely gets close to the 3 gigs limit of the game (32-bit). Using 7000x7000 images are massive on RAM usage, I'd suggest setting all your decks images to max 4096x4096. Unity can compress power of two images much better and RAM uses will be a lot less compared to some of those 7k images (7k image is 3 times as large as a 4k image). Also combining decks so that the entire texture sheet is being used will help a bunch, because that black part of the image is just eating up RAM.

    Let me know if you run into any more issues!

  13. #13
    Join Date
    Mar 2014
    Posts
    15

    Custom card decks are white upon opening save file

    So far so good! I've got just about everything in now, this is as far along as I've ever been and it's not showing any of the hangups I was getting at 60-70% completed. I combined a lot of my existing card decks, shaving off a few total images used, and shrunk almost all to 4096, I'm sure that helped. I kept a couple large images because they were for charts with a lot of small text, I'll keep an eye on them if I have any more crashes. Thanks for all the help allowing me to push past the issues and see it through.

  14. #14
    Join Date
    Jan 2014
    Posts
    998

    Custom card decks are white upon opening save file

    No worries, glad it's working out better now. I need to add some more documentation to Wiki for best practices with modding.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •