Results 1 to 7 of 7

Thread: Having Trouble Working With Atom+Lua Plugin

  1. #1

    Having Trouble Working With Atom+Lua Plugin

    I hope this is the right place for this. I've installed Atom and intend to utilize the Lua plugin to ease development of a project. However, it is being extremely finicky and I am unsure if it is an error with my setup or something else. I can open Atom and run 'Get Lua Scripts' just fine. When I go to 'Save And Play' the scripts, that also works fine insofar as the game loads the script and reloads, applying the effect. The problem is that Atom then sometimes closes one or more scripts and both 'Get Lua Scripts' and 'Save And Play' do nothing any longer. I'm forced to completely close and reopen Atom every time I want to apply changes since I only get one "push" to the game before it breaks.

    Can anyone help with this? Thanks.

  2. #2
    Install the portable version of Atom. That fixed it for me.

  3. #3
    Where can I find this? There doesn't seem to be anything on the official page about a "portable" version. I see some links to files on sourceforge and others that are labeled as portable but one did not even run, the other behaved identically. Could you provide for me the exact Atom version you are using?

  4. #4
    [url]https://github.com/garethflowers/atom-portable/releases/[/url]

    It fixed the issue for me for an hour or two, letting Atom actually function properly. Then, it stopped working altogether for me, not showing any scripts even after restarting or even deleting and redownloading it.

  5. #5
    Sorry to hear that it was working for you at one point and then stopped. Unfortunately, even on this fresh Windows install, never having had Atom installed even, the version you linked behaved identically. Loads once, saves one, then I have to reopen Atom. Thanks anyway though.

  6. #6
    So I've isolated the issue to a single object script that is exceedingly simple, but it contains the only #includes in the mod. I suspect something is causing Atom to handle this poorly and error out. In the console, I get this:

    fs.js:584 Uncaught Error: EPERM: operation not permitted, open 'C:\Users\Joe\AppData\Local\Temp\TabletopSimulator \Tabletop Simulator Lua\Pawns.fb1455.ttslua'
    at Object.fs.openSync (fs.js:584:18)
    I'm not familiar enough with how the tts plugin and json works to figure this out, but if I remove the script with the #includes, everything works perfectly. I can save and load as much as I want.

  7. #7
    Well, it worked great for all of an afternoon... Now, if I change anything in any file and attempt to save it, I get the same error message as before but for the file that I changed. It can be something as little as a single space somewhere for it to break. This is quite frustrating.

Similar Threads

  1. Atom Text Editor Plugin Feedback
    By Dan K in forum Scripting
    Replies: 187
    Last Post: 07-09-2020, 09:53 PM
  2. Atom Plugin Integration
    By seemslegit in forum Scripting
    Replies: 15
    Last Post: 09-15-2018, 07:20 AM
  3. Replies: 9
    Last Post: 11-12-2017, 11:58 AM
  4. Atom Plugin Linting
    By onelivesleft in forum Scripting
    Replies: 0
    Last Post: 10-02-2017, 01:19 PM
  5. Atom plugin not handling some characters
    By dzikakulka in forum Scripting
    Replies: 2
    Last Post: 05-12-2016, 07:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •