Results 1 to 14 of 14

Thread: TTS and Atom recently stopped communicating (Mac)

  1. #1

    TTS and Atom recently stopped communicating (Mac)

    I have been working with TTS and Atom on my same Mac for nearly a year with no problems until last week. Funky errors started happening with permissions, then I got a missing project folder error, and it hasn't worked since. None of those errors are happening any longer though - so it's now very difficult to figure out how to debug.

    The Current Situation:

    TTS, Atom, and the Tabletopsimulator Lua package are all up-to-date.

    I load up TTS, and load up a game (any game - same result with everything), and then open up Atom, and then select the "Get Lua Scripts" option from the TTS menu. It then shows a blue box that says: "Received files from TTS: 0 updated | 0 opened | 0 removed.".

    I have enabled the Verbose logging in the TTS Lua package settings in Atom, and this is the output in the log:

    Listening to localhost:39998 /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Checking for tabletopsimulator-lua updates:
    Package Updates Available (0) /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Checking for tabletopsimulator-lua updates:
    └── (empty) /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Sending request to TTS... /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Sent.  /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Received message from TTS: [1] TTS_MSG_NEW_GAME  /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    Received files from TTS: 0 updated | 0 opened | 0 removed.  /Users/prattski/.atom/packages/tabletopsimulator-lua/lib/
    So there are no errors that I'm seeing anywhere. I just seems that there's no communication happening between Atom and TTS, and I have no idea how to debug this. Hoping someone would be willing to point me in the right direction.

    Things I've Tried Already:

    • Restarting my computer
    • Uninstalling/Reinstalling Tabletop Simulator
    • Uninstalling/Reinstalling Atom & TTS Lua package
    • Clearing cache
    • Running "Install Shell Commands" in Atom

    Thank you,

  2. #2
    Join Date
    May 2016
    [url][/url] Check out the last post I made in this thread (about the new version of the plug in and verbose logging) for the "next steps" on this issue.

  3. #3
    Mr. Stump - I had actually already read that thread prior to creating my post here. I have already enabled Verbose logging, and I already tried removing the folder (which it did end up creating a new one), but Atom is still not communicating with TTS. The output of the log in this post above is after verbose logging was enabled, and that's all it's showing.. So unfortunately that post did not help to fix my problem.

  4. #4
    Join Date
    Jan 2014
    Are your scripts in general still working ingame we've had reports of scripting mac not working in general?

  5. #5
    Knil - Yes, TTS seems to be working as normal. I've loaded up numerous games and have played them without issue. The only problem is that Atom won't connect to TTS so I can't script at all using it.

  6. #6
    Can you turn on the external API logging in TTS and see what happens at that end? [URL=""]See here for details[/URL].

  7. #7
    onelivesleft - I enabled api logging, and then ran the "Get Lua Scripts", and this was the output in the log:

    EXT: \ Datastream started.
    EXT:  | JSON complete
    EXT:  | Sleeping until main thread finishes <2>
    EXT:  | Handled message: GetScripts
    EXT: / Datastream ended.
    I'm wondering if the location that Atom is expecting the TTS files is not aligned with where TTS is putting them, or perhaps the symlinks are messed up if it uses those to link the directories?

    The folder that Atom seems to be assuming the project files should be is: /var/folders/j8/[long string]/T/TabletopSimulator/Tabletop Simulator Lua

    Just a guess - but I have no idea how to figure that out if that's the case.

  8. #8
    Thanks, that's useful info. I'll see if I can work out what's happening.

  9. #9
    onelivesleft - If you feel it would be helpful, I'd be willing to connect on Discord/Skype/etc. and screenshare at some point if you'd like to take a closer look.

  10. #10
    I've updated the plugin to v10.6.2, which gives more info when logging, if you can test it again and check out what's happening. Anything with a red > before it can be expanded. Also, what is your "Communication with Tabletop Simulator" setting set to (it's the first one)?

  11. #11
    onelivesleft - Well, it appears that your update did more than just add additional logging. It is now working properly! And I didn't change any settings, restart my computer, or anything.

    The setting I have for that is "Do not automatically open any files sent from Tabletop Simulator"

    So what else did you change? Any idea what have made it start working properly again besides extra logging?

  12. #12
    I fixed that setting! It was governing what was received from TTS instead of what was opened.

  13. #13
    Ahhhh - Very interesting. Yeah it was sure odd that one day it seemed to work fine, and the next it was totally broken. Thank you very much for fixing that - much appreciated!!

  14. #14
    Forum moderators: This thread can be marked as resolved (I'm not sure how to do it..)

Similar Threads

  1. Replies: 16
    Last Post: 04-04-2018, 07:02 PM
  2. [SOLVED] Terrible VOIP Quality Recently
    By Supercon in forum Technical Support
    Replies: 6
    Last Post: 05-26-2017, 03:52 PM
  3. [CRASHES] .exe Has Stopped Working
    By Tpakonen in forum Technical Support
    Replies: 1
    Last Post: 05-26-2017, 03:49 PM
  4. [SUPPORT] Mic Stopped Working after last patch
    By mrwigggles in forum Technical Support
    Replies: 1
    Last Post: 04-18-2017, 02:42 PM
  5. CTD: vrserver.exe has stopped working
    By Bushstar in forum VR Support
    Replies: 1
    Last Post: 01-10-2017, 04:31 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts