Results 1 to 7 of 7

Thread: Linux (Ubuntu 19.10) Periodic Refresh Rate Erroring That Requires Lobby Reload

  1. #1

    Linux (Ubuntu 19.10) Periodic Refresh Rate Erroring That Requires Lobby Reload

    Every 5-10 minutes in Tabletop Simulator on Ubuntu 19.10, this bug where it appears the redrawing of the window fails happens. It requires either a game or a lobby reload to fix, and I have noticed nothing that happens in the game to really cause it. It's happened in both workshop and classic games, so I do not think it is scripted or modded content that causes this. I have uploaded a video of what happens after the bug triggers.

    (Sorry for the streamlabs element in view, I forgot to disable it when recording)

  2. #2
    Looks like I'm having the same issue on Ubuntu 18.04.4. I tried to gather some logs using the -log launch parameter, but the log file is nowhere to be found. Definitely not ~/.config/unity3d/Berserk Games/Tabletop Simulator/Player.log as stated on the TTS community page.

  3. #3
    Here are some of my findings regarding this; hopefully it will help the devs...

    1. The issue starts ~5 minutes into the game
    2. The first symptom is when using the "Zoom object" functionality. Only the zoomed object and UI are redrawn properly. The rest of the game seems to be redrawn without clearing the screen. After releasing the zoom button, the game area gets redrawn normally.
    3. At this point, the next "draw" to the hand completely kills the rendering of the game. At this point the only elements that are correctly redrawn are: the hand and the UI. The rest of the game - as previously - seems to be redrawn without clearing the screen. This is particularly visible when opening a UI window and dragging it across the screen.
    4. Flipping the table makes the game refresh, but then... there's no game left to play. I guess it's because you're loosing your hand then? Anyway, undoing the table flip kills the rendering again.
    5. From a hot-seat game perspective: ending your turn makes the game render properly again. But, only until the next player decides to draw / use zoom. I guess that's also due to the fact that the other player may have an empty hand at this time. Anyway, even if the second player does not draw and keeps his hand empty, once he ends his turn and it goes back to you, the issue instantly returns.

    I guess that emptying your hand would temporarily make the game renderable again, but I have not tried it. It would break again while zooming / holding anything in your hand, though.

    Hope this helps, as the bug is really annoying.

    Also, I've tried with -force-opengl and -force-gfx-st (this was mentioned in the Troubleshooting section in the Knowledge Base). With no effect, the problem still happens. CPU, memory usage and system load also look normal.
    For the record, I'm playing on Dell Latitude E7450. Maybe that'll help a bit.

  4. #4
    If anybody is having similar issues, the workaround for this (at least the one that worked for me) is to disable Hand View in the UI settings. The redraw glitch still appears when using Zoom object after at least 5 minutes of game time, but as soon as you leave the Zoom object mode, the main game area redraws normally.

    Another workaround is to force Proton instead of native Linux runtime, but I had degraded performance when doing so.

    I hope the developers will look into it.

  5. #5
    I'm having the same issue, as noted in another thread, with one interesting observation.

    This happens ONLY when I have created the game. I have completed multiple 2-4 hour games that I have joined without this issue coming up at all.

  6. #6
    I'm having this issue as well! Interestingly, it seems to only happen to the host. My friend has the same OS (PopOS 18.04) and laptop, and when I change him to host, the issue resolves for me but starts for him after about 5 min.

  7. #7
    I've had the issue on Ubuntu 19.10 using an AMD RX470, but it went away when I installed updated graphics drivers from , which upgraded the Mesa version from 19.2 to 20.1

    This doesn't mean there's no bug in the game, but it could well be that the problem will go away with the Ubuntu 20.04 update rolling out next month.

Similar Threads

  1. lookAt() Parameters for Position and Yaw Smoothing Rate
    By Ender13 in forum Scripting Suggestions
    Replies: 4
    Last Post: 11-11-2018, 07:38 PM
  2. [CRASHES] LINUX - Cannot open the game in either Ubuntu v 18 or Arch
    By Nekasus in forum Technical Support
    Replies: 0
    Last Post: 07-17-2018, 01:37 PM
  3. [SOLVED] Heavy Memory Usage, Frame Rate Drops, Crashes
    By in forum Technical Support
    Replies: 10
    Last Post: 09-03-2017, 06:38 PM
  4. [SOLVED] Server Browser hanging on load/refresh
    By Uraja in forum Technical Support
    Replies: 1
    Last Post: 11-27-2016, 02:36 AM
  5. Replies: 1
    Last Post: 06-16-2016, 12:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts