Results 1 to 10 of 10

Thread: Idling TTS on Mac renders Google Chrome unusable

  1. #1

    Idling TTS on Mac renders Google Chrome unusable


    Sometimes I want to play a game while also using Google Chrome intermittently. Running TTS on my 2016 macbook pro on macOS 10.14.6 causes Chrome to run at around 0.3 fps regardless of the settings I use or whether I'm just idling at the launch screen. That's not great.

  2. #2
    I realized this was happening to my computer even when Chrome was closed. Rebooted in safe mode and then updated macOS to 10.15.3

  3. #3
    If you have data loss problem after macOS update, EaseUS Data Recovery Wizard for Mac provides tried-and-true data recovery service to you.

  4. #4
    I'm also having this issue. Basically, when TTS is running, Chrome and Chromium-based apps like Steam, Discord, etc are really laggy - for example, opening a new tab takes seconds. It doesn't happen with any other app - even very intensive ones. It happens even in the TTS menu, not even in a game yet.

    I'm using 10.14.6 with an up-to-date Chrome.

    I tried reproducing this on a different Mac that had 10.15 and didn't see this issue. However, on that Mac, I got a prompt like the following[1] saying that TTS wants keystrokes from every application - which is apparently a new warning in 10.15. I wonder if it's related? Is TTS hooking global system input handlers and slowing these apps down?

    Is there a reason TTS requires this permission? Can it be disabled?


  5. #5
    This post suggests that the CGEventTapCreate API can cause that permission prompt:

    Does TTS use that API and if so, what for?

  6. #6
    Searching elsewhere also shows that other APIs can trigger this. I've not been able to find an exhaustive list of APIs, but apparently IOHIDManagerRegisterInputValueCallback could also be related. Here's a fix SDL did where they were using that API:

  7. #7
    I've found these apple developer docs about the APIs that can trigger this:

  8. #8
    One interesting thing - if I start TTS in lldb and break, the problem doesn't happen. So it makes me think it's not related to the input even stuff.

    I also tried lowering TTS's graphics settings and it helped quite a bit. Given this happens when I switch TTS to background, would it be possible to have TTS automatically lower its graphics settings when in background? Or throttle its graphics updates otherwise?

  9. #9
    Is there some better place to report the issue like a bug tracker?

  10. #10
    Helenawe, thanks for your advice. The problem was solved.

Similar Threads

  1. [SUPPORT] Screen pixelates out and becomes unusable on Ubuntu
    By h3ihjnah in forum Technical Support
    Replies: 5
    Last Post: 04-01-2020, 01:41 PM
  2. Replies: 2
    Last Post: 02-12-2018, 07:22 PM
  3. [SOLVED] Tutorial/Singleplayer/Multiplayer Unusable
    By Rhuun in forum Technical Support
    Replies: 2
    Last Post: 12-30-2015, 05:49 PM
  4. [SOLVED] Custom model renders as pure black
    By Frohman in forum Technical Support
    Replies: 3
    Last Post: 10-29-2015, 12:33 PM
  5. Google cardboard ?
    By bobb in forum General Discussion
    Replies: 3
    Last Post: 03-15-2015, 03:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts