The context menu is bugged when I create a model one after the other:
For the first model:
- In the first tab(Model), I insert the OBJ link(in model and collider) the Diffuse image link, make it Non-Convex, and set the Type to "Coin".
- I switch to the 2nd tab(Material), I set the Material to "Wood", Specular Intensity to 0, Specular Sharpness all the way down to 2.00, and Fresnel Strength all the way down to 0.00
[URL="http://i.imgur.com/UVdidjDl.jpg"]First Model Settings Screenshot[/URL]
Now, I go BACK to the first tab(Model), before I hit the IMPORT button.
The model imports and comes out as expected. But now the settings are screwed up when I do it again:
[URL="http://i.imgur.com/oYN1oRa.jpg"]Settings when going to make the 2nd Custom 3D Model[/URL]

When the settings are in this state,
- in the first tab(Model), the Type will be fixed if you click something besides "Coin" or "Generic".
- in the 2nd tab(Material), Wood is still selected, but if you click on Plastic, it will not change to Plastic, because it's assuming that you have Plastic selected already. To fix it, I have to switch it over to Metal, and then over to Wood again.

Now, I've proceeded to fix it how I said above, and import another model. I make the same model, but this time I click Import when in the 2nd tab(Material). After fixing the settings, the model is fine, and as expected.

Now I go to make a 3rd model:
[URL="http://i.imgur.com/INIfKDw.jpg"]Settings when going to make the 3rd Model[/URL]
- The Context window appears on the Material tab(which is why it's on the left in the above link), and is fine,
- when I switch to the Model tab, the Type is on "Coin", which is the previous model's type. But if I left it that way, and proceeded to make the model without modifying that section, the model would not have the "Coin" attribute, it would be "Generic". The Type section has the same issue as the previous model did in the Material tab with selecting what Material it was(Plastic, Wood, Metal), and it assumes it's already got "Generic" selected. So if you try and switch it from "Coin" to "Generic" it will not work until you pick one of the others first(other than "Coin" or "Generic"), and then you can select "Coin" again, and it will work.

I'm unsure if this occurs with any of the other Types or Materials.